Project Security Advisories

Subscribe to Project Security Advisories feed
Updated: 47 min 37 sec ago

Responsive Menus - Moderately critical - Cross site scripting - SA-CONTRIB-2018-079

Wed, 12/05/2018 - 2:34pm
Project: Responsive MenusVersion: 7.x-1.x-devDate: 2018-December-05Security risk: Moderately critical 13∕25 AC:Basic/A:Admin/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross site scriptingDescription: 

This module enables you to collapse your sites main menu on mobile, and show a menu toggle button.

The module doesn't sufficiently sanitize configuration settings provided by users which leads to a Cross Site Scripting (XSS) vulnerability.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer responsive menus".

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Salesforce Suite - Moderately critical - Access bypass - SA-CONTRIB-2018-078

Wed, 12/05/2018 - 2:24pm
Project: Salesforce SuiteDate: 2018-December-05Security risk: Moderately critical 14∕25 AC:None/A:None/CI:Some/II:None/E:Theoretical/TD:DefaultVulnerability: Access bypassDescription: 

This module enables Drupal to synchronize entities with Salesforce records. The module includes a page that does not sufficiently protect access rights, resulting in potential information disclosure.

This vulnerability is mitigated by the fact that only Drupal entity title and IDs, and Salesforce record IDs are exposed. Entity content and metadata are appropriately protected. Disclosure of Salesforce ID does not confer any additional privileges.

Solution: 

Install the latest version:

Also see the Salesforce Suite project page.

Reported By: Fixed By: Coordinated By: 

Password Policy - Less critical - Denial of Service - SA-CONTRIB-2018-077

Wed, 12/05/2018 - 2:21pm
Project: Password PolicyVersion: 7.x-1.x-devDate: 2018-December-05Security risk: Less critical 9∕25 AC:Basic/A:None/CI:None/II:None/E:Theoretical/TD:DefaultVulnerability: Denial of ServiceDescription: 

The Password Policy module makes it possible to set constraints on user passwords which disallow certain passwords.

The "digit placement" constraint is vulnerable to Denial of Service attacks if an attacker submits specially crafted passwords which can cause a site to become unresponsive.

This vulnerability is mitigated by the fact that a site must have the "digit placement" constraint enabled.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Date Reminder - Moderately critical - Access bypass - SA-CONTRIB-2018-076

Wed, 11/28/2018 - 1:01pm
Project: Date ReminderDate: 2018-November-28Security risk: Moderately critical 10∕25 AC:Basic/A:User/CI:Some/II:None/E:Theoretical/TD:DefaultVulnerability: Access bypassDescription: 

This module allows registered users to request email reminders to be sent at a specified time before an event.

The module doesn't sufficiently check access to nodes, allowing a user to set a reminder on a node that the user shouldn't be able to access.

This can be mitigated with configuring DateReminder with Reminder Display: "Fieldset within a node" disables the potential exploit.

Solution: 

Install the latest version:

Also see the Date Reminder project page.

Reported By: Fixed By: Coordinated By: 
  • Balazs Janos Tatar Provisional Security Team member
  • GatherContent - Moderately critical - Access bypass - SA-CONTRIB-2018-075

    Wed, 11/28/2018 - 12:51pm
    Project: GatherContentDate: 2018-November-28Security risk: Moderately critical 13∕25 AC:Basic/A:None/CI:Some/II:None/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

    This module enables you to import and export data from the GatherContent service.

    The module didn't properly protect its administrative paths.

    Solution: 
    • gathercontent 7.x versions prior to 7.x-3.5.

    Drupal core is not affected. If you do not use the contributed GatherContent module, there is nothing you need to do.

    Solution

    Install the latest version:

    Reported By: Fixed By: Coordinated By: 

    Bootstrap - Moderately critical - Cross site scripting - SA-CONTRIB-2018-074

    Wed, 11/28/2018 - 12:32pm
    Project: BootstrapVersion: 7.x-3.228.x-3.14Date: 2018-November-28Security risk: Moderately critical 11∕25 AC:Complex/A:User/CI:Some/II:Some/E:Theoretical/TD:UncommonVulnerability: Cross site scriptingDescription: 

    This base theme bridges the gap between Drupal and the Bootstrap Framework.

    The theme doesn't sufficiently filter valid targets under the scenario of opening modals, popovers, and tooltips.

    This vulnerability is mitigated by the fact that an attacker must already have the ability to either:

    1. Edit/save custom content that supplies a value for the data-target attribute by injecting malicious code.
    2. Inject custom markup onto the page that further exploits the data-target attribute by injecting malicious code. This method of attack is highly unlikely if they already have this level of access.

    Note: while the base-theme does not provide either of these opportunities to do this out-of-the-box; a custom sub-theme may, however, be susceptible if it didn't sanitize or filter user provided input for XSS properly.

    Solution: 

    Install the latest version and take additional manual steps (see below).

    • If you use the Drupal Bootstrap base-theme for Drupal 7.x, upgrade to 7.x-3.22
    • If you use the Drupal Bootstrap base-theme for Drupal 8.x, upgrade to 8.x-3.14

    Extra Note:

    The vulnerability fixed in the Bootstrap theme releases on Drupal.org is a by-product from forking parts of the external framework's JavaScript code. The external framework's vulnerability was first reported in a public issue and later a fix for this vulnerability was merged into the external framework, however an official release of the external framework has yet to be made.

    Users of this theme should take two additional steps:

    1. Follow this external framework issue for further information and to keep up-to-date on when you need to upgrade your sub-theme's external framework source. You may consider using the distributed files from the temporary branch master-xmr-v3-fixes until an official release is made.
    2. Review any custom code on your site that might have copied from the external framework's vulnerable code.

    Also see the Bootstrap project page.

    Reported By: Fixed By: Coordinated By: 

    Paragraphs - Moderately critical - Access Bypass - SA-CONTRIB-2018-073

    Wed, 10/31/2018 - 1:53pm
    Project: ParagraphsVersion: 8.x-1.4Date: 2018-October-31Security risk: Moderately critical 10∕25 AC:Complex/A:None/CI:None/II:Some/E:Theoretical/TD:UncommonVulnerability: Access BypassDescription: 

    The Paragraphs module allows Drupal Site Builders to make content organization cleaner so that you can give more editing power to end-users.

    The module doesn't sufficiently check access to create new paragraph entities which can cause access bypass issues when used in combination with other contributed modules.

    Solution: 

    Install the latest version:

    Also see the Paragraphs project page.

    Reported By: Fixed By: Coordinated By: 

    Session Limit - Critical - Insecure Session Management - SA-CONTRIB-2018-072

    Wed, 10/31/2018 - 11:12am
    Project: Session LimitVersion: 7.x-2.28.x-1.0-beta2Date: 2018-October-31Security risk: Critical 15∕25 AC:Complex/A:None/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Insecure Session ManagementDescription: 

    The session limit module enables a site administrator to set a policy around the number of active sessions users of the site may have. This is typically set to one so that you can only be logged in once with the same user account.

    In one configuration of the module, when a user logs in with another session elsewhere already active, the module asks the user which session should be closed before they can proceed with login. The module does not sufficiently tokenise the list of sessions so that the user's session keys can be found through inspection of the form.

    This vulnerability is mitigated by the fact that an attacker must already be able to intercept the contents of the HTML page to exploit the issue. That ability to intercept may come from Cross Site Scripting. This makes a Cross Site Scripting vulnerability worse than it would normally be.

    Solution: 

    Install the latest version:

    • If you use the Session Limit module for Drupal 7.x, upgrade to 7.x-2.3
    • If you use the Session Limit module for Drupal 8.x, upgrade to 8.x-1.0-beta3

    Also see the Session Limit project page.

    Reported By: Fixed By: Coordinated By: 

    Decoupled Router - Critical - Access bypass - SA-CONTRIB-2018- 071

    Wed, 10/31/2018 - 10:59am
    Project: Decoupled RouterVersion: 8.x-1.18.x-1.0Date: 2018-October-31Security risk: Critical 15∕25 AC:None/A:None/CI:Some/II:None/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

    This module enables you to resolve the provided Drupal path in order to find the canonical path and information about the resolved entity. This information includes entity type ID, entity ID, entity UUID and entity label.

    The module doesn't sufficiently check access before displaying entity labels. This leads to the display of labels on entities that are not be accessible, for example; titles of unpublished content.

    Solution: 

    Install the latest version:

    Also see the Decoupled Router project page.

    Reported By: Fixed By: Coordinated By: 

    Search Autocomplete - Moderately critical - Cross Site Scripting - SA-CONTRIB-2018-070

    Wed, 10/17/2018 - 6:14pm
    Project: Search AutocompleteDate: 2018-October-17Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross Site ScriptingCVE IDs: CVE-2018-7603Description: 

    This Search Autocomplete module enables you to autocomplete textfield using data from your website (nodes, comments, etc..).

    The module doesn't sufficiently filter user-entered text among the autocompletion items leading to a Cross Site Scripting (XSS) vulnerability.

    This vulnerability can be exploited by any user allowed to create one of the autocompletion item, for instance, nodes, users, comments.

    Solution: 

    Install the latest version:

    Also see the Search Autocomplete project page.

    Reported By: Fixed By: Coordinated By: 

    HTML Mail - Critical - Remote Code Execution - SA-CONTRIB-2018-069

    Wed, 10/17/2018 - 2:16pm
    Project: HTML MailDate: 2018-October-17Security risk: Critical 17∕25 AC:Basic/A:Admin/CI:All/II:All/E:Theoretical/TD:AllVulnerability: Remote Code ExecutionDescription: 

    The HTML Mail module lets you theme your messages the same way you theme the rest of your website.

    When sending email some variables were not being sanitized for shell arguments, which could lead to remote code execution.

    This issue is related to the Drupal Core release SA-CORE-2018-006.

    Solution: 

    Install the latest version:

    • If you are running Drupal 7.x,
      • update to 7.x-2.71.
      • In case you're still using 7.x-2.65, there is a version 7.x-2.66 which has only the security patch applied, but you must realize that you are running old code and you're missing a number of bug fixes.

    Also see the HTML Mail project page.

    Reported By: Fixed By: Coordinated By: 

    Mime Mail - Critical - Remote Code Execution - SA-CONTRIB-2018-068

    Wed, 10/17/2018 - 1:06pm
    Project: Mime MailDate: 2018-October-17Security risk: Critical 17∕25 AC:Basic/A:User/CI:All/II:All/E:Theoretical/TD:DefaultVulnerability: Remote Code ExecutionDescription: 

    The MIME Mail module allows to send MIME-encoded e-mail messages with embedded images and attachments.

    The module doesn't sufficiently sanitized some variables for shell arguments when sending email, which could lead to arbitrary remote code execution.

    This issue is related to the Drupal Core release SA-CORE-2018-006.

    Solution: 

    Install the latest version:

    Also see the Mime Mail project page.

    Reported By: Fixed By: Coordinated By: 

    Workbench Moderation - Moderately critical - Access bypass - SA-CONTRIB-2018-067

    Wed, 10/17/2018 - 12:29pm
    Project: Workbench ModerationDate: 2018-October-17Security risk: Moderately critical 11∕25 AC:Complex/A:User/CI:Some/II:Some/E:Theoretical/TD:UncommonVulnerability: Access bypassDescription: 

    The Workbench Moderation module adds arbitrary moderation states to Drupal core's "unpublished" and "published" node states, and affects the behavior of node revisions when nodes are published.

    In some conditions, content moderation fails to check a users access to use certain transitions, leading to an access bypass.

    This issue is related to the Drupal Core release SA-CORE-2018-006.

    Solution: 

    Install the latest version:

    Also see the Drupal core project page.

    Reported By: Fixed By: Coordinated By: 

    NVP field - Moderately critical - Cross Site Scripting - SA-CONTRIB-2018-066

    Wed, 10/10/2018 - 1:02pm
    Project: NVP fieldDate: 2018-October-10Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross Site ScriptingDescription: 

    NVP field module allows you to create a field type of name/value pairs, with custom
    titles and easily editable rendering with customizable HTML/text surrounding the pairs.

    The module doesn't sufficiently handle sanitization of its field formatter's output.

    This vulnerability is mitigated by the fact that an attacker must have a role with the permission of creating/editing content where the module defined fields are in use.

    Solution: 

    Install the latest version:

    Also see the NVP field project page.

    Reported By: Fixed By: Coordinated By: 

    Search API Solr Search - Moderately critical - Access bypass - SA-CONTRIB-2018-065

    Wed, 10/10/2018 - 1:01pm
    Project: Search API Solr SearchVersion: 7.x-1.13Date: 2018-October-10Security risk: Moderately critical 10∕25 AC:Complex/A:None/CI:Some/II:None/E:Theoretical/TD:UncommonVulnerability: Access bypassDescription: 

    This module provides support for creating searches using the Apache Solr search engine and the Search API Drupal module.

    The module doesn't sufficiently take the searched fulltext fields into account when creating a search excerpt. This can, in specific cases, lead to confidential data being leaked as part of the search excerpt.

    Solution: 

    Install the latest version:

    Also see the Search API Solr Search project page.

    Reported By: Fixed By: Coordinated By: 

    Lightbox2 - Critical - Cross Site Scripting - SA-CONTRIB-2018-064

    Wed, 10/10/2018 - 12:57pm
    Project: Lightbox2Version: 7.x-2.x-devDate: 2018-October-10Security risk: Critical 18∕25 AC:None/A:None/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross Site ScriptingDescription: 

    The Lightbox2 module enables you to overlay images on the current page.

    The module did not sanitize some inputs when used in combination with a custom view leading to potential Cross Site Scripting (XSS).

    Solution: 

    Install the latest version:

    Also see the Lightbox2 project page.

    Reported By: Fixed By: Coordinated By: 

    Printer, email and PDF versions - Highly critical - Remote Code Execution - SA-CONTRIB-2018-063

    Wed, 10/03/2018 - 2:18pm
    Project: Printer, email and PDF versionsVersion: 7.x-2.x-devDate: 2018-October-03Security risk: Highly critical 20∕25 AC:None/A:None/CI:All/II:All/E:Theoretical/TD:UncommonVulnerability: Remote Code ExecutionDescription: 

    This module provides printer-friendly versions of content, including send by e-mail and PDF versions.

    The module doesn't sufficiently sanitize the arguments passed to the wkhtmltopdf executable, allowing a remote attacker to execute arbitrary shell commands. It also doesn't sufficiently sanitize the HTML content passed to dompdf, allowing a privileged attacker to execute arbitrary PHP code.

    This vulnerability is mitigated by the fact that the site must have either the wkhtmltopdf or dompdf sub-modules enabled and selected as the PDF generation tool. In the case of the dompdf vulnerability, the attacker must be able to write content to the site.

    Solution: 

    Install the latest version:

    • If you use the print module for Drupal 7.x, upgrade to print 7.x-2.1

    In alternative, disable PDF generation, or replace the PDF generation library with another of the supported versions.

    Also see the Printer, email and PDF versions project page.

    Reported By: Fixed By: Coordinated By: 

    Commerce Klarna Checkout - Moderately critical - Access bypass - SA-CONTRIB-2018-062

    Wed, 09/26/2018 - 12:34pm
    Project: Commerce Klarna CheckoutVersion: 7.x-1.4Date: 2018-September-26Security risk: Moderately critical 13∕25 AC:Basic/A:None/CI:None/II:Some/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

    The Commerce Klarna Checkout module enables you to accept payments from the Klarna Checkout payment provider

    The module doesn't sufficiently validate the payment callback made by Klarna. An attacker could bypass the payment step.

    Solution: 

    Install the latest version:

    Also see the Commerce Klarna Checkout project page.

    Reported By: Fixed By: Coordinated By: 

    Taxonomy File Tree - Moderately critical - Access bypass - SA-CONTRIB-2018-061

    Wed, 09/26/2018 - 12:12pm
    Project: Taxonomy File TreeVersion: 7.x-1.0Date: 2018-September-26Security risk: Moderately critical 13∕25 AC:Basic/A:None/CI:Some/II:None/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

    Taxonomy File Tree allows site managers to create file trees.

    For files managed as Drupal files, the module does not properly check that a user has access to a file before letting the user download the file.

    This vulnerability only affects sites that use private files.

    Solution: 

    Install the latest version:

    Also see the Taxonomy File Tree project page.

    Reported By: Fixed By: Coordinated By: 

    Renderkit - Moderately critical - Access bypass - SA-CONTRIB-2018-060

    Wed, 09/19/2018 - 12:02pm
    Project: RenderkitDate: 2018-September-19Security risk: Moderately critical 11∕25 AC:Basic/A:None/CI:Some/II:None/E:Theoretical/TD:UncommonVulnerability: Access bypassDescription: 

    This module, typically in combination with cfr:cfrplugin, allows to compose behaviors from granular components. One of such behaviors is to display a list of related entities, for a given source entity and a given entity relation (e.g. an entity reference field).

    The components that display related content do not check if the user has access to view the related entities. This way e.g. unpublished nodes may be displayed to anonymous visitors.

    This vulnerability is mitigated by the facts that
    - a site builder must have used the component that displays "related" entities for a source entity, using cfr:cfrplugin, OR a programmer has used one of the affected components in code.
    - a source entity displayed this way must reference access-restricted content.

    Solution: 

    Install the latest version:

    Also see the Renderkit project page.

    Reported By: Fixed By: Coordinated By: 

    Pages